北京金桥世纪H3C认证培训全国总代理

将路由器作为FTP Server传输文件

2011/11/15 13:40:00互联网

将路由器作为FTP Server传输文件
应用环境
NE40E支持作为FTP服务器进行文件操作。当路由器作为FTP服务器时,不需要第三方软件的支持。在路由器启动FTP服务器功能后,可以直接进行文件上传和下载操作。

配置思路
在将路由器作为FTP Server传输文件时,采用如下的配置思路:

1.         确保路由器和FTP客户端之间有可达路由

2.         在路由器上启用FTP Server功能

3.         创建本地用户

4.         保存配置

配置注意事项
在将路由器作为FTP Server时,一定要配置本地用户。

配置实例
组网需求
如下图所示,RouterA作为FTP服务器,并创建FTP用户quidway,密码为huawei。RouterC从FTP服务器下载文件到本地。

利用FTP功能下载文件

 将路由器作为FTP Server传输文件

适用产品和版本
采用NE40E/80E/5000E路由器,版本为(VRP5.10)及后续版本

配置步骤
步骤 1     配置各路由器接口的IP地址并配置RIP路由协议。

# 配置RouterA

<RouterA> system-view

[RouterA] interface gigabitethernet1/0/0

[RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 8

[RouterA-GigabitEthernet1/0/0] quit

[RouterA] rip 100

[RouterA-rip-100] network 10.0.0.0

# 配置RouterB

<RouterB> system-view

[RouterB] interface gigabitethernet1/0/0

[RouterB-GigabitEthernet1/0/0] ip address 10.1.1.2 8

[RouterB-GigabitEthernet1/0/0] quit

[RouterB] interface gigabitethernet2/0/0

[RouterB-GigabitEthernet2/0/0] ip address 172.16.1.1 16

[RouterB-GigabitEthernet2/0/0] quit

[RouterB] rip 100

[RouterB-rip-100] network 10.0.0.0

[RouterB-rip-100] network 172.16.0.0

[RouterB-rip-100] quit

# 配置RouterC

<RouterC> system-view

[RouterC] interface gigabitethernet2/0/0

[RouterC-GigabitEthernet2/0/0] ip address 172.16.1.2 16

[RouterC-GigabitEthernet2/0/0] quit

[RouterC] rip 100

[RouterC-rip-100] network 172.16.0.0

[RouterC-rip-100] quit

步骤 2     在RouterA上使能FTP Server功能,并创建FTP访问控制列表,只允许172.16.0.0的网段的用户访问RouterA。

[RouterA] ftp server enable

[RouterA] acl 2000

[RouterA-acl-basic-2001] rule 1 permit source 172.16.0.0 0

[RouterA-acl-basic-2001] quit

[RouterA] ftp acl 2000

步骤 3     在RouterA上创建FTP用户

[RouterA] aaa

[RouterA-aaa] local-user quidway password simple huawei

[RouterA-aaa] local-user quidway service-type ftp

[RouterA-aaa] local-user quidway ftp-directory cfcard:/ftp/Quidway

[RouterA-aaa] quit

步骤 4     保存配置

# 配置RouterA

[RouterA] quit

<RouterA> save

# 配置RouterB

[RouterB] quit

<RouterB> save

# 配置RouterC

[RouterC] quit

<RouterC> save

验证结果
步骤 1     在RouterC上能够以FTP方式登录RouterA。

<RouterC> ftp 10.1.1.1

Trying 10.1.1.1 ...

Connected to 10.1.1.1.

220 WFTPD 2.0 service (by Texas Imperial Software) ready for new user

User(10.1.1.1:(none)):quidway

331 Give me your password, please

Password:

230 Logged in successfully

[ftp]

步骤 2     在RouterB上不能够以FTP方式登录RouterA。

<RouterB> ftp 10.1.1.1

Trying 10.1.1.1 ...

Connected to 10.1.1.1.

220 WFTPD 2.0 service (by Texas Imperial Software) ready for new user

User(10.1.1.1:(none)):quidway

331 Give me your password, please

Password:

230 Logged in successfully

ftp>

配置文件
RouterA的配置文件
#

sysname RouterA

#

interface GigabitEthernet1/0/0

ip address 10.1.1.1 255.0.0.0

#

rip 100

  network 10.0.0.0

#

return

RouterB的配置文件
#

sysname RouterB

#

interface GigabitEthernet1/0/0

ip address 10.1.1.2 255.0.0.0

#

interface GigabitEthernet2/0/0

ip address 172.16.1.1 255.255.0.0

#

rip 100

  network 10.0.0.0

  network 172.16.0.0

#

return

RouterC的配置文件
#

sysname RouterC

#

interface GigabitEthernet2/0/0

ip address 172.16.1.2 255.255.0.0

#

rip 100

  network 172.16.0.0

#

return

 


·[优惠活动]H3CTE笔试加实验考试精讲班,火热报名中! 
·[金桥动态]金桥世纪和多家上市公司合作,为您提供良好的就业机 
·[知识课堂]【H3C技术】S5500-EI系列交换机万兆堆叠端口“不可 
·[金桥动态]金桥世纪无线网络工程师定向培训高薪就业! 
·[知识课堂]【H3C技术】S36005600系列交换机堆叠方法及注意事 
·[金桥动态]新版H3CSE-R&S认证发布,开创网络认证新纪元 


点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息


开班信息

10月15

H3CNE认证

热报中

10月22

H3C-IMC认证

热报中

10月15

H3CNE认证

热报中

10月22

H3CTE认证

热报中

10月22

H3C-IMC认证

热报中

10月15

H3CNE培训

热报中

10月22

H3CSE认证

热报中

10月15

H3C无线

热报中

10月22

H3CSE培训

热报中

10月29

H3CIMC培训

热报中

10月15

H3C无线培训

热报中

10月29

H3CEAD培训

热报中

10月22

H3CPME认证

热报中

10月29

H3C安全认证

热报中

10月22

H3CIMC培训

热报中

10月15

H3C无线培训

热报中

10月22

H3CEAD培训

热报中

10月22

H3CPME认证

热报中

10月29

H3C安全认证

热报中

10月22

H3CIMC培训

热报中

10月15

H3C无线培训

热报中

10月22

H3CEAD培训

热报中

10月22

H3CPME认证

热报中

10月29

H3C安全认证

热报中

点击咨询开班情况>>

在线咨询