北京金桥世纪H3C认证培训全国总代理

将路由器作为FTP Client传输文件

2011/11/15 13:40:00互联网

将路由器作为FTP Client传输文件
应用环境
当需要把文件服务器上的文件下载到路由器上时,需要将路由器作为FTP客户端,文件服务器作为FTP服务器端。这种方式需要在文件服务器上有第三方软件的支持,并使用第三方软件创建FTP用户。

完成上述配置后,在路由器上运行FTP并输入FTP用户名和密码,就可以进行文件上传和下载操作。

配置思路
在将路由器作为FTP Client传输文件时,采用如下的配置思路:

1.         确保路由器和FTP服务器之间有可达路由

2.         在FTP服务器上运行FTP软件并创建FTP用户

3.         保存配置

配置注意事项
在将路由器作为FTP Client时,一定要使用FTP软件创建FTP用户。

配置实例
组网需求
如下图所示,RouterA作为FTP Client,要从FTP Server下载文件到本地。FTP Server运行Windows操作系统。

利用FTP功能下载文件

 将路由器作为FTP Client传输文件

适用产品和版本
采用NE40E/80E/5000E路由器,版本为(VRP5.10)及后续版本

配置步骤
步骤 1     配置各路由器接口的IP地址并配置RIP路由协议。

# 配置RouterA

<RouterA> system-view

[RouterA] interface gigabitethernet1/0/0

[RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 8

[RouterA-GigabitEthernet1/0/0] quit

[RouterA] rip 100

[RouterA-rip-100] network 10.0.0.0

# 配置RouterB

<RouterB> system-view

[RouterB] interface gigabitethernet1/0/0

[RouterB-GigabitEthernet1/0/0] ip address 10.1.1.2 8

[RouterB-GigabitEthernet1/0/0] quit

[RouterB] interface gigabitethernet2/0/0

[RouterB-GigabitEthernet2/0/0] ip address 172.16.1.1 16

[RouterB-GigabitEthernet2/0/0] quit

[RouterB] rip 100

[RouterB-rip-100] network 10.0.0.0

[RouterB-rip-100] network 172.16.0.0

[RouterB-rip-100] quit

步骤 2     配置FTP Server

# 将RouterB的GigabitEthernet2/0/0接口的IP地址作为FTP Server的网关,如下图所示。

配置FTP Server的网关地址

 将路由器作为FTP Client传输文件

步骤 3     在FTP Server上运行FTP软件

说明

FTP软件有多种,此处以WFTP为例进行说明。

# WFTP界面如下图所示

WFTP界面

 将路由器作为FTP Client传输文件

# 打开[Security]菜单,选择[Users/rights…]菜单项,打开[Users/Rights Security Dialog]窗口,如下图所示。

新建用户

 将路由器作为FTP Client传输文件

# 单击<New User…>按钮,新建用户名及密码。

创建用户

 将路由器作为FTP Client传输文件

输入密码

 将路由器作为FTP Client传输文件

# 单击<OK>按钮,返回[Users/Rights Security Dialog]窗口,选择刚才创建的用户名,单击<Done>按钮。

验证结果
在RouterA执行FTP命令可以登录到FTP Server。

<RouterA> ftp 172.16.1.2

Trying 172.16.1.2 ...

Connected to 172.16.1.2.

220 WFTPD 2.0 service (by Texas Imperial Software) ready for new user

User(172.16.1.2:(none)):quidway

331 Give me your password, please

Password:

230 Logged in successfully

ftp>

配置文件
RouterA的配置文件
#

sysname RouterA

#

interface GigabitEthernet1/0/0

ip address 10.1.1.1 255.0.0.0

#

rip 100

  network 10.0.0.0

#

return

RouterB的配置文件
#

sysname RouterB

#

interface GigabitEthernet1/0/0

ip address 10.1.1.2 255.0.0.0

#

interface GigabitEthernet2/0/0

ip address 172.16.1.1 255.255.0.0

#

rip 100

  network 10.0.0.0

  network 172.16.0.0

#

return


·[优惠活动]H3CTE笔试加实验考试精讲班,火热报名中! 
·[知识课堂]WLAN一体化安全 
·[行业资讯]城域IP骨干网的变革已经到来 
·[知识课堂]H3C配合执法机构维护渠道市场秩序 
·[知识课堂]【H3C技术】H3C无线网络工程实施 
·[知识课堂]H3C推802.11n产品引领企业级无线市场 


点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息


开班信息

05月07

H3CNE认证

热报中

05月21

H3C-IMC认证

热报中

05月07

H3CNE认证

热报中

05月07

H3CTE认证

热报中

05月21

H3C-IMC认证

热报中

05月07

H3CNE培训

热报中

05月28

H3CSE认证

热报中

05月21

H3C无线

热报中

05月28

H3CSE培训

热报中

05月21

H3CIMC培训

热报中

05月28

H3C无线培训

热报中

05月28

H3CEAD培训

热报中

05月28

H3CPME认证

热报中

05月21

H3C安全认证

热报中

05月28

H3CIMC培训

热报中

05月21

H3C无线培训

热报中

05月28

H3CEAD培训

热报中

05月21

H3CPME认证

热报中

05月21

H3C安全认证

热报中

05月21

H3CIMC培训

热报中

05月28

H3C无线培训

热报中

05月28

H3CEAD培训

热报中

05月28

H3CPME认证

热报中

05月21

H3C安全认证

热报中

点击咨询开班情况>>

在线咨询