北京金桥世纪H3C认证培训全国总代理

【H3C技术】H3C三层交换机VLAN配置实例详解

2012-7-31 11:33:04互联网

  <H3C>

  <H3C>dis cu

  #

  sysname H3C

  #

  radius scheme system

  #

  domain system

  #

  acl number 2011

  rule 0 deny

  rule 1 permit source 172.16.11.0 0.0.0.255

  acl number 2012

  rule 0 deny

  rule 1 permit source 172.16.12.0 0.0.0.255

  acl number 2013

  rule 0 deny

  rule 1 permit source 172.16.13.0 0.0.0.255

  acl number 2021

  rule 0 deny

  rule 1 permit source 172.16.21.0 0.0.0.255

  acl number 2022

  rule 0 deny

  rule 1 permit source 172.16.22.0 0.0.0.255

  acl number 2023

  rule 0 deny

  rule 1 permit source 172.16.23.0 0.0.0.255

  acl number 2031

  rule 0 deny

  rule 1 permit source 172.16.31.0 0.0.0.255

  acl number 2032

  rule 0 deny

  rule 1 permit source 172.16.32.0 0.0.0.255

  acl number 2033

  rule 0 deny

  rule 1 permit source 172.16.33.0 0.0.0.255

  acl number 2041

  rule 0 deny

  rule 1 permit source 172.16.41.0 0.0.0.255

  acl number 2042

  rule 0 deny

  rule 1 permit source 172.16.42.0 0.0.0.255

  acl number 2043

  rule 0 deny

  rule 1 permit source 172.16.43.0 0.0.0.255

  acl number 2080

  rule 0 deny

  rule 1 permit source 172.16.80.0 0.0.0.255

  #

  vlan 1

  #

  vlan 11

  #

  vlan 12

  #

  vlan 13

  #

  vlan 21

  #

  vlan 22

  #

  vlan 23

  #

  vlan 31

  #

  vlan 32

  #

  vlan 33

  #

  vlan 41

  #

  vlan 42

  #

  vlan 43

  #

  vlan 80

  #

  interface Aux1/0/0

  #

  interface Ethernet1/0/1

  port link-type hybrid

  port hybrid vlan 1 11 untagged

  port hybrid pvid vlan 11

  packet-filter inbound ip-group 2011 rule 0

  packet-filter inbound ip-group 2011 rule 1

  #

  interface Ethernet1/0/2

  port link-type hybrid

  port hybrid vlan 1 12 untagged

  port hybrid pvid vlan 12

  packet-filter inbound ip-group 2012 rule 0

  packet-filter inbound ip-group 2012 rule 1

  #

  interface Ethernet1/0/3

  port link-type hybrid

  port hybrid vlan 1 13 untagged

  port hybrid pvid vlan 13

  packet-filter inbound ip-group 2013 rule 0

  packet-filter inbound ip-group 2013 rule 1

  #

  interface Ethernet1/0/4

  port link-type hybrid

  port hybrid vlan 1 21 untagged

  port hybrid pvid vlan 21

  packet-filter inbound ip-group 2021 rule 0

  packet-filter inbound ip-group 2021 rule 1

  #

  interface Ethernet1/0/5

  port link-type hybrid

  port hybrid vlan 1 22 untagged

  port hybrid pvid vlan 22

  packet-filter inbound ip-group 2022 rule 0

  packet-filter inbound ip-group 2022 rule 1

  #

  interface Ethernet1/0/6

  port link-type hybrid

  port hybrid vlan 1 23 untagged

  port hybrid pvid vlan 23

  packet-filter inbound ip-group 2023 rule 0

  packet-filter inbound ip-group 2023 rule 1

  #

  interface Ethernet1/0/7

  port link-type hybrid

  port hybrid vlan 1 31 untagged

  port hybrid pvid vlan 31

  packet-filter inbound ip-group 2031 rule 0

  packet-filter inbound ip-group 2031 rule 1

  #

  interface Ethernet1/0/8

  port link-type hybrid

  port hybrid vlan 1 32 untagged

  port hybrid pvid vlan 32

  packet-filter inbound ip-group 2032 rule 0

  packet-filter inbound ip-group 2032 rule 1

  #

  interface Ethernet1/0/9

  port link-type hybrid

  port hybrid vlan 1 33 untagged

  port hybrid pvid vlan 33

  packet-filter inbound ip-group 2033 rule 0

  packet-filter inbound ip-group 2033 rule 1

  #

  interface Ethernet1/0/10

  port link-type hybrid

  port hybrid vlan 1 41 untagged

  port hybrid pvid vlan 41

  packet-filter inbound ip-group 2041 rule 0

  packet-filter inbound ip-group 2041 rule 1

  #

  interface Ethernet1/0/11

  port link-type hybrid

  port hybrid vlan 1 42 untagged

  port hybrid pvid vlan 42

  packet-filter inbound ip-group 2042 rule 0

  packet-filter inbound ip-group 2042 rule 1

  #

  interface Ethernet1/0/12

  port link-type hybrid

  port hybrid vlan 1 43 untagged

  port hybrid pvid vlan 43

  packet-filter inbound ip-group 2043 rule 0

  packet-filter inbound ip-group 2043 rule 1

  #

  interface Ethernet1/0/13

  #

  interface Ethernet1/0/14

  #

  interface Ethernet1/0/15

  #

  interface Ethernet1/0/16

  #

  interface Ethernet1/0/17

  #

  interface Ethernet1/0/18

  #

  interface Ethernet1/0/19

  #

  interface Ethernet1/0/20

  port link-type hybrid

  port hybrid vlan 1 80 untagged

  port hybrid pvid vlan 80

  packet-filter inbound ip-group 2080 rule 0

  packet-filter inbound ip-group 2080 rule 1

  #

  interface Ethernet1/0/21

  #

  interface Ethernet1/0/22

  port link-type hybrid

  port hybrid vlan 1 11 to 13 21 to 23 31 to 33 41 to 43 80 untagged

  #

  interface Ethernet1/0/23

  port link-type hybrid

  port hybrid vlan 1 11 to 13 21 to 23 31 to 33 41 to 43 80 untagged

  #

  interface Ethernet1/0/24

  port link-type hybrid

  port hybrid vlan 1 11 to 13 21 to 23 31 to 33 41 to 43 80 untagged

  #

  interface GigabitEthernet1/1/1

  #

  interface GigabitEthernet1/1/2

  #

  interface GigabitEthernet1/1/3

  port link-type hybrid

  port hybrid vlan 1 11 to 13 21 to 23 31 to 33 41 to 43 80 untagged

  #

  interface GigabitEthernet1/1/4

  port link-type hybrid

  port hybrid vlan 1 11 to 13 21 to 23 31 to 33 41 to 43 80 untagged

  #

  undo irf-fabric authentication-mode

  #

  interface NULL0

  #

  user-interface aux 0 7

  user-interface vty 0 4

  #

  return

  F100-C的设置问题回复

  方法一:

  F100-C恢复出厂设置,你以前的配置就会删除了,你可以重新配置你的固定IP配置

  固定IP配置实例:

  [H3C]dis cur

  #

  sysname H3C

  #

  firewall packet-filter enable

  firewall packet-filter default permit

  #

  insulate

  #

  undo connection-limit enable

  connection-limit default deny

  connection-limit default amount upper-limit 50 lower-limit 20

  #

  nat address-group 1 218.94.*.* 218.94.*.*

  #

  firewall statistic system enable

  #

  radius scheme system

  #

  domain system

  #

  local-user wjm

  password simple wjm

  service-type telnet

  level 3

  #

  acl number 2000 match-order auto

  rule 0 permit source 192.168.0.0 0.0.255.255

  #

  interface Aux0

  async mode flow

  #

  interface Ethernet0/0

  ip address 192.168.0.1 255.255.255.0

  #

  interface Ethernet0/1

  #

  interface Ethernet0/2

  #

  interface Ethernet0/3

  #

  interface Ethernet1/0

  ip address 218.94.*.* 255.255.255.240

  #

  interface Ethernet1/1

  #

  interface Ethernet1/2

  #

  interface NULL0

  #

  firewall zone local

  set priority 100

  #

  firewall zone trust

  add interface Ethernet0/0

  add interface Ethernet0/1

  add interface Ethernet0/2

  add interface Ethernet0/3

  set priority 85

  #

  firewall zone untrust

  add interface Ethernet1/0

  add interface Ethernet1/1

  add interface Ethernet1/2

  set priority 5

  #

  firewall zone DMZ

  set priority 50

  #

  firewall interzone local trust

  #

  firewall interzone local untrust

  #

  firewall interzone local DMZ

  #

  firewall interzone trust untrust

  #

  firewall interzone trust DMZ

  #

  firewall interzone DMZ untrust

  #

  ip route-static 0.0.0.0 0.0.0.0 218.94.*.*preference 60

  #

  #

  user-interface con 0

  user-interface aux 0

  user-interface vty 0 4

  authentication-mode scheme

  #

  return

  华为交换机配置命令

  本文网址:http://bbs.bitscn.com/121555 复制

  华为QuidWay交换机配置命令手册:

  1、开始

  建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。

  在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。

  以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如)。

  键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?"

  2、命令视图

  (1)用户视图(查看交换机的简单运行状态和统计信息):与交换机建立连接即进入

  (2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view

  (3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface ethernet 0/1

  (4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan 1

  (5)VLAN接口视图(配置VLAN和VLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface vlan-interface 1

  (6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user user1

  (7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface

  3、其他命令

  设置系统时间和时区clock time Beijing add 8

  clock datetime 12:00:00 2005/01/23

  设置交换机的名称[Quidway]sysname TRAIN-3026-1[TRAIN-3026-1]

  配置用户登录[Quidway]user-interface vty 0 4

  [Quidway-ui-vty0]authentication-mode scheme

  创建本地用户[Quidway]local-user huawei

  [Quidway-luser-huawei]password simple huawei

  [Quidway-luser-huawei] service-type telnet level 3

  4、VLAN配置方法

  『配置环境参数』

  SwitchA端口E0/1属于VLAN2,E0/2属于VLAN3

  『组网需求』

  把交换机端口E0/1加入到VLAN2 ,E0/2加入到VLAN3

  数据配置步骤

  『VLAN配置流程』

  (1)缺省情况下所有端口都属于VLAN 1,并且端口是access端口,一个access端口只能属于一个vlan;

  (2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;

  (3)除了VLAN1,如果VLAN XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。

  【SwitchA相关配置】

  方法一:

  (1)创建(进入)vlan2

  [SwitchA]vlan 2

  (2)将端口E0/1加入到vlan2

  [SwitchA-vlan2]port ethernet 0/1

  (3)创建(进入)vlan3

  [SwitchA-vlan2]vlan 3

  (4)将端口E0/2加入到vlan3

  [SwitchA-vlan3]port ethernet 0/2

  方法二:

  (1)创建(进入)vlan2

  [SwitchA]vlan 2

  (2)进入端口E0/1视图

  [SwitchA]interface ethernet 0/1

  (3)指定端口E0/1属于vlan2

  [SwitchA-Ethernet1]port access vlan 2

  (4)创建(进入)vlan3

  [SwitchA]vlan 3

  (5)进入端口E0/2视图

  [SwitchA]interface ethernet 0/2

  (6)指定端口E0/2属于vlan3

  [SwitchA-Ethernet2]port access vlan 3

  测试验证

  (1)使用命令disp cur可以看到端口E0/1属于vlan2,E0/2属于vlan3;

  (2)使用display interface Ethernet 0/1可以看到端口为access端口,PVID为2;

  (3)使用display interface Ethernet 0/2可以看到端口为access端口,PVID为3

  5、交换机IP地址配置

  功能需求及组网说明

  『配置环境参数』

  三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan 2、vlan 3;

  以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关;

  以vlan 3的三层接口地址分别是2.0.0.1/24作为PC2的网关;

  『组网需求』

  PC1和PC2通过三层接口互通

  【SwitchA相关配置】

  (1)创建(进入)vlan2

  [Quidway]vlan 2

  (2)将端口E0/1加入到vlan2

  [Quidway-vlan2]port ethernet 0/1

  (3)进入vlan2的虚接口

  [Quidway-vlan2]interface vlan 2

  (4)在vlan2的虚接口上配置IP地址

  [Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0

  (5)创建(进入)vlan3

  [Quidway]vlan 3

  (6)将E0/2加入到vlan3

  [Quidway-vlan3]port ethernet 0/2

  (7)进入vlan3的虚接口

  [Quidway-vlan3]interface vlan 3

  (8)在vlan3的虚接口上配置IP地址

  [Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0

  测试验证

  (1)PC1和PC2都可以PING通自己的网关

  (2)PC1和PC2可以相互PING通

  6、端口的trunk配置

  『配置环境参数』

  (1)SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连

  (2)SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连

  『组网需求』

  (1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通

  (2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通

  数据配置步骤

  【SwitchA相关配置】

  (1)创建(进入)vlan10

  [SwitchA] vlan 10

  (2)将E0/1加入到vlan10

  [SwitchA-vlan10]port Ethernet 0/1

  (3)创建(进入)vlan20

  [SwitchA]vlan 20

  (4)将E0/2加入到vlan20

  [SwitchA-vlan20]port Ethernet 0/2

  (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

  [SwitchA-Ethernet0/3]port link-type trunk

  (6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

  [SwitchA-Ethernet0/3]port trunk permit vlan all

  【SwitchB相关配置】

  (1)创建(进入)vlan10

  [SwitchB] vlan 10

  (2)将E0/1加入到vlan10

  [SwitchB-vlan10]port Ethernet 0/1

  (3)创建(进入)vlan20

  [SwitchB]vlan 20

  (4)将E0/2加入到vlan20

  [SwitchB-vlan20]port Ethernet 0/2

  (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

  [SwitchB-Ethernet0/3]port link-type trunk

  (7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

  [SwitchB-Ethernet0/3]port trunk permit vlan all

  【补充说明】

  (1)如果一个端口是trunk端口,则该端口可以属于多个vlan;

  (2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID;

  (3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。

  (4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。

  (5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。

  测试验证

  (1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通

  (2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通

  (3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通

  (4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通

  7、端口汇聚配置

  『配置环境参数』

  (1)交换机SwitchA和SwitchB通过以太网口实现互连。

  (2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。

  『组网需求』

  增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚

  数据配置步骤

  【SwitchA交换机配置】

  (1)进入端口E0/1

  [SwitchA]interface Ethernet 0/1

  (2)汇聚端口必须工作在全双工模式

  [SwitchA-Ethernet0/1]duplex full

  (3)汇聚的端口速率要求相同,但不能是自适应

  [SwitchA-Ethernet0/1]speed 100

  (4)进入端口E0/2

  [SwitchA]interface Ethernet 0/2

  (5)汇聚端口必须工作在全双工模式

  [SwitchA-Ethernet0/2]duplex full

  (6)汇聚的端口速率要求相同,但不能是自适应

  [SwitchA-Ethernet0/2]speed 100

  (7)根据源和目的MAC进行端口选择汇聚

  [SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

  【SwitchB交换机配置】

  [SwitchB]interface Ethernet 0/1

  [SwitchB-Ethernet0/1]duplex full

  [SwitchB-Ethernet0/1]speed 100

  [SwitchB]interface Ethernet 0/2

  [SwitchB-Ethernet0/2]duplex full

  [SwitchB-Ethernet0/2]speed 100

  [SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

  【补充说明】

  (1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。

  (2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

  8、端口镜像配置

  『环境配置参数』

  (1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24

  (2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24

  (3)E0/24为交换机上行端口

  (4)Server接在交换机E0/8端口,该端口作为镜像端口

  『组网需求』

  (1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

  根据Quidway交换机不同型号,镜像有不同方式进行配置:

  基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

  基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

  S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像

  8016交换机支持基于端口的镜像

  3500/3026E/3026F/3050支持基于流的镜像

  5516/6506/6503/6506R支持对入端口流量进行镜像

  数据配置步骤

  以Quidway S3026C为例,通过基于二层流的镜像进行配置:

  (1)定义一个ACL

  [SwitchA]acl num 200

  (2)定义一个规则从E0/1发送至其它所有端口的数据包

  [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

  (3)定义一个规则从其它所有端口到E0/1端口的数据包

  [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

  (4)将符合上述ACL的数据包镜像到E0/8

  [SwitchA]mirrored-to link-group 200 interface e0/8

  9、生成树STP配置

  『配置环境参数』

  (1)交换机SwitchA、SwitchB和SwitchC都通过GE接口互连

  (2)SwitchB和SwitchC交换机是核心交换机,要求主备。

  『组网需求』

  要求整个网络运行STP协议

  数据配置步骤

  (1)【SwitchA交换机配置】

  启动生成树协议: [SwitchA]stp enable

  (1)【SwitchB交换机配置】

  启动生成树协议:[SwitchB]stp enable

  (3)配置本桥为根桥

  [SwitchB]stp root primary

  (4)【SwitchC交换机配置】

  a 启动生成树协议[SwitchC]stp enable

  b 配置本桥为备份根桥[SwitchC]stp root secondary

  (5)【SwitchD交换机配置】

  a 启动生成树协议[SwitchD]stp enable

  【补充说明】

  (1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优先级来实现;

  (2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式;

  (3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。

  测试验证

  (1)使用display stp查看交换机STP运行状态

  (2)查看端口STP状态display stp interface Ethernet XX是否正确

  10、Quidway交换机维护

  显示系统版本信息:display version

  显示诊断信息:display diagnostic-information

  显示系统当前配置:display current-configuration

  显示系统保存配置: display saved-configuration

  显示接口信息:display interface

  显示路由信息:display ip routing-table

  显示VLAN信息:display vlan

  显示生成树信息:display stp

  显示MAC地址表:display mac-address

  显示ARP表信息:display arp

  显示系统CPU使用率:display cpu

  显示系统内存使用率:display memory

  显示系统日志:display log

  显示系统时钟:display clock

  验证配置正确后,使用保存配置命令:save

  删除某条命令,一般使用命令: undo

 

 

 

 

 


·[优惠活动]H3CTE笔试加实验考试精讲班,火热报名中! 
·[知识课堂]H3C WLAN助力流通企业信息化 
·[就业指导]网络相关专业学生应该考取H3C认证 
·[知识课堂]WiFi语音解决方案 
·[就业岗位]上海仙琴信息技术有限公司紧急招聘网络工程师 
·[知识课堂]H3C运营级无线校园网解决方案 


点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息


开班信息

10月16

H3CTE认证

热报中

09月25

H3CSE认证

热报中

09月25

H3CNE认证

热报中

10月16

H3CTE认证

热报中

09月25

H3CSE认证

热报中

09月25

H3CNE培训

热报中

10月16

H3CTE认证

热报中

10月23

H3C云计算

热报中

09月25

H3CNE培训

热报中

10月16

H3CIMC培训

热报中

10月16

H3C无线培训

热报中

10月09

H3CEAD培训

热报中

10月16

H3CPME认证

热报中

10月23

H3C安全认证

热报中

10月16

H3CIMC培训

热报中

10月16

H3C无线培训

热报中

10月09

H3CEAD培训

热报中

10月09

H3CPME认证

热报中

10月23

H3C安全认证

热报中

10月16

H3CIMC培训

热报中

10月16

H3C无线培训

热报中

10月09

H3CEAD培训

热报中

10月09

H3CPME认证

热报中

10月23

H3C安全认证

热报中

点击咨询开班情况>>

在线咨询