北京金桥世纪H3C认证培训全国总代理

【H3C培训】cisco与H3C命令比较

2012-8-17 9:13:19本站原创

功能

Cisco命令

H3C命令

      进入全局模式

#configure terminal

<Quidway>system

      显示当前配置

show running-config

display current-configuration

      显示版本信息

show version

display version

      显示vlan信息

show vlan

display vlan

      显示接口信息

show interface接口

display interface接口

      交换机路由器
命名

hostname主机名

sysname主机名

      修改特权密码

enable password密码(明文)
enable secret密码(密文)

super password密码

      进入接口模式

interface接口

interface接口

      进入vlan模式

interface vlan vlan号

interface vlan vlan号

      给接口配IP

ip address <ip> <掩码>

ip address <ip> <掩码>

      配telnet密码

line vty 0 4
password密码
login

user-interface vty 0 4
authentication-mode password
set authentication-mode password simple密码
user privilege level 3

      激活端口

no shutdown

undo shutdown

      关闭端口

shutdown

shutdown

      退出

exit

quit

      创建VLAN

vlan vlan号

vlan  vlan号

     VLAN中增加
端口

 

port e0/1
port e0/2 to e0/4

      当前端口加入
到VLAN

switchport access vlan vlan号

port access vlan vlan号

      设置端口工作
模式

switchport mode trunk|access|dynamic

port link-type trunk|access|hybrid

      设trunk允许的
VLAN

switchport trunk allowed vlan remove|add ID

port trunk permit vlan  ID|All

      指定镜像端口

monitor session 1 destination int接口

monitor-port接口

      指定被镜像端

monitor session 1 source int接口 both

port mirror接口

      设置生成树启
动与否

spanning-tree vlan vlan号(默认开启)

stp enable|disable(默认关闭)

      端口的聚合

interface range f0/1 – 4
channel-group 1 mode on

link-aggregation e0/1 to e0/4 ingress|both
undo link-aggregation e0/1|all

      设置主vlan

 

isolate-user-vlan enable

      设置主vlan包括
的子vlan

 

isolate-user-vlan <x>  secondary <vlan-list>

      显示路由信息

show ip route

display ip route

      绑定HDLC协议

默认就是

link-protocol hdlc

      设静态路由

ip route网络号掩码下一跳IP/接口

ip route-static网络号掩码下一跳IP/接口

      启用RIP路由

router rip

rip
rip work
rip input
rip output

      配置路由器的
ID

int loopback 0
ip add  IP地址掩码

router id  A.B.C.D

      启动OSPF协议

router ospf进程号

ospf enable

      配置OSPF区域

net网络号反向掩码 area <area_id>

int接口
ospf enable area <area_id>

      标准ACL命令格

access-list列表号 permit|deny源IP
反向掩码

acl <acl-number> [match-order config|auto]                  
rule [normal|special]{permit|deny} [source source-addr source-wildcard|any]

      扩展ACL配置

access-list列表号 permit|deny协议源IP反向掩码目的IP反向掩码 eq端口号

acl <acl-number> [match-order config|auto]
rule{normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any} eq服务名

            PPP设置

encapsulation ppp

link-protocol ppp

            Pap认证

主认证方
(config)#username用户名 password密码
(config)#int串口接口
(config-if)#ppp authentication pap
被认证方
(config)#int串口接口
(config-if)#ppp pap sent-username用户名 password密码

主认证方
local-user用户名password {simple|cipher}密码     
interface串口接口
ppp authentication-mode pap
被认证方
interface串口接口
ppp pap local-user用户名 password {simple|cipher}密码

             Chap认证

主认证方
(config)#username客户端主机名 password密码
(config)#int串口接口
(config-if)#ppp authentication
(config-if)#ppp chap hostname服务器主机名
被认证方
(config)#username服务器主机名 password密码
(config)#int串口接口
(config-if)#ppp chap hostname客户端主机名

主认证方
local-user对方主机名password {simple|cipher}密码     
interface串口接口
ppp authentication-mode chap
ppp chap user自己主机名
被认证方
interface串口接口
local-user对方主机名 password {simple|cipher}密码
ppp chap user自己主机名

       静态nat

(1)为内外部接口配IP并激活;
(2)在接口上启用NAT;
内部接口:ip nat inside
外部接口:ip nat outside
(3)建立静态地址转换
(config)#ip nat inside source static 私有IP   公网IP

interface接口
nat server global <ip> [port] inside <ip> port [protocol]

       动态NAT

(1)为内外部接口配IP并激活;
(2)在接口上启用NAT;
内部接口:ip nat inside
外部接口:ip nat outside
(3)定义内网允许访问外网的ACL
(config)#access-list列表号 permit源IP  反向掩码
(4)定义合法IP地址池
(config)#ip nat pool地址池名  公网起始IP  公网终止IP   netmask  掩码
(5)实现地址转换
(config)#ip nat inside source list列表号 pool地址池名

(1)   建立地址池
nat address-group公网起始IP  公网终止IP pool 1
(2)定义内网允许访问外网的ACL
acl列表号
rule permit source 源IP  反向掩码         rule deny source any
(3)实现地址转换
int公网接口
nat outbound列表号address-group pool 1


·[就业指导]H3C网络学院巡回讲座—北京黄庄职高专场 
·[就业指导]网络相关专业学生应该考取H3C认证 
·[就业岗位]上海仙琴信息技术有限公司紧急招聘网络工程师 
·[知识课堂]【H3C】H3C路由器转发失败故障解决方法 
·[金桥动态]第六期H3C就业集训营开班 
·[就业指导]开学了,周末不能再荒废 


点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息


开班信息

10月16

H3CTE认证

热报中

09月25

H3CSE认证

热报中

09月25

H3CNE认证

热报中

10月16

H3CTE认证

热报中

09月25

H3CSE认证

热报中

09月25

H3CNE培训

热报中

10月16

H3CTE认证

热报中

10月23

H3C云计算

热报中

09月25

H3CNE培训

热报中

10月16

H3CIMC培训

热报中

10月16

H3C无线培训

热报中

10月09

H3CEAD培训

热报中

10月16

H3CPME认证

热报中

10月23

H3C安全认证

热报中

10月16

H3CIMC培训

热报中

10月16

H3C无线培训

热报中

10月09

H3CEAD培训

热报中

10月09

H3CPME认证

热报中

10月23

H3C安全认证

热报中

10月16

H3CIMC培训

热报中

10月16

H3C无线培训

热报中

10月09

H3CEAD培训

热报中

10月09

H3CPME认证

热报中

10月23

H3C安全认证

热报中

点击咨询开班情况>>

在线咨询