北京金桥世纪H3C认证培训全国总代理

【H3C技术】部署DHCP中继

2011-11-15 13:39:39互联网

部署DHCP中继
应用环境
如果本地网络没有配置DHCP服务器,可以在路由器上启动DHCP中继功能,从客户端来的DHCP请求可通过DHCP中继传到DHCP服务器。

说明

服务器和客户端之间的DHCP中继不能超过4次,否则DHCP报文将被丢弃。

配置思路
在部署DHCP中继时,采用如下的配置思路:

配置RouterB到RouterA与客户端相连接口GE1/0/0的路由
配置DHCP中继路由器RouerA
使能DHCP功能
配置要实现DHCP中继功能的接口,包括IP地址、子网掩码等
在接口配置IP中继地址
使能接口的DHCP中继功能
说明

IP中继地址是指在作为DHCP中继的设备上所指定的DHCP服务器的IP地址。当配置DHCP中继功能时。从该接口上收到的DHCP广播报文被送到指定DHCP服务器。

配置注意事项
需要注意的是:

使能接口的DHCP中继功能前应先配置接口的IP地址。
配置的IP中继地址应和地址池中的IP地址段属于同一网段。
由于DHCP客户端在DHCP配置的某些阶段发送的报文为广播报文,因此启动IP中继功能的接口应当支持广播方式。
每个接口最多可以配置20个中继地址。
配置实例
组网需求
如下图,DHCP客户端所在的网段为10.100.0.0,而DHCP服务器所在的网段为202.40.0.0。需要通过带DHCP中继功能的路由器中继DHCP报文,使得DHCP客户端可以从DHCP服务器上申请到IP地址等相关配置信息。

DHCP服务器应当分配一个10.100.0.0网段的IP地址池,以便将适当的IP地址分配给该网段上的DHCP客户端,并且DHCP服务器上应当配置有到10.100.0.0网段的路由。

DHCP中继配置

 【H3C技术】部署DHCP中继

适用的产品和版本
NE系列的路由器,版本为VRP5.30及后续版本。

配置步骤
步骤 1     在DHCP中继上进行配置

# 使能DHCP服务。

<RouterA> system-view

[RouterA] dhcp enable

# 配置接口POS2/0/0接口地址。

[RouterA] interface pos 2/0/0

[RouterA-Pos2/0/0] ip address 202.40.1.1 255.255.0.0

# 进入要实现DHCP中继功能的接口,为其配置IP地址和地址掩码以使其和DHCP客户端属于同一个网段。

[RouterA] interface gigabitethernet 1/0/0

[RouterA-GigabitEthernet1/0/0] ip address 10.100.1.1 255.255.0.0

[RouterA-GigabitEthernet1/0/0] ip relay address 202.40.1.2

[RouterA-GigabitEthernet1/0/0] dhcp select relay

步骤 2     在DHCP服务器上进行配置

# 配置RouterB到RouterA与客户端相连接口GE1/0/0的路由。

<RouterB> system-view

[RouterB] ip route-static 10.100.0.0 255.255.0.0 202.40.1.1

# 启动DHCP服务。

[RouterB] dhcp enable

# 配置接口POS1/0/0下的客户端从全局地址池中获取IP地址。

[RouterB] interface pos 1/0/0

[RouterB-Pos1/0/0] ip address 202.40.1.2 255.255.0.0

[RouterB-Pos1/0/0] dhcp select global

# 配置不参与自动分配的IP地址(包括DNS服务器地址、NetBIOS和出口网关地址)。

[RouterB] dhcp server forbidden-ip 10.100.1.2

[RouterB] dhcp server forbidden-ip 10.100.1.3

[RouterB] dhcp server forbidden-ip 10.100.1.4

# 配置DHCP地址池1属性(地址池范围、域名、出口网关、DNS地址、地址租用期)。

[RouterB] dhcp server ip-pool 1

[RouterB-dhcp-1] network 10.100.0.0 mask 255.255.0.0

[RouterB-dhcp-1] domain-name huawei.com

[RouterB-dhcp-1] dns-list 10.100.1.2

[RouterB-dhcp-1] nbns-list 10.100.1.3

[RouterB-dhcp-1] gateway-list 10.100.1.4

[RouterB-dhcp-1] expired day 10 hour 12

[RouterB-dhcp-1] quit

验证结果
在DHCP服务器上使用display dhcp server ip-in-use命令用来查看DHCP客户端的地址绑定信息,如硬件地址、IP地址、地址租用期限等信息。

<Router> display dhcp server ip-in-use all

Global pool:

 IP address     Hardware address    Lease expiration              Type

 10.1.1.5       00e0-fc00-c559      Dec 26 2006 16:22:58 PM       Auto:COMMITED

10.1.1.6       00e0-fc00-c560      Dec 26 2006 16:24:58 PM       Auto:COMMITED

 

Interface pool:

 IP address     Hardware address    Lease expiration              Type

                                                                                            

在DHCP中继上,使用display dhcp relay address命令用来查看接口的DHCP中继地址配置情况。

<RouterA> display dhcp relay address all

               ** GigabitEthernet1/0/0 DHCP Relay Address  **

                  Relay Address [0] :     202.40.1.2    

配置文件
# DHCP中继路由器RouterA配置文件

#

 sysname RouterA

#

interface GigabitEthernet1/0/0

 ip address 10.100.1.1 255.255.0.0

 ip relay address 202.40.1.2

 dhcp select relay

#

interface Pos 2/0/0

 ip address 202.40.1.1 255.255.0.0

#

return

 

# DHCP服务器路由器RouterB配置文件

#

 sysname RouterB

#

interface Pos 1/0/0

ip address 202.40.1.2 255.255.0.0

 dhcp select global

#

dhcp server ip-pool 1

network 10.100.0.0 mask 255.255.0.0

domain-name huawei.com

 dns-list 10.100.1.2

nbns-list 10.100.1.3

gateway-list 10.100.1.4

expired day 10 hour 12

#

dhcp server forbidden-ip 10.100.1.2

dhcp server forbidden-ip 10.100.1.3

dhcp server forbidden-ip 10.100.1.4

#

ip route-static 10.100.0.0 255.255.0.0 202.40.1.1

#

return


·[知识课堂]WLAN增值业务展望 
·[金桥动态]北京金桥世纪王斌老师到北京工业职业学院开展讲座 
·[知识课堂]H3C无线网络助力第17届WWW2008 
·[知识课堂]H3C无线运营管理解决方案 
·[知识课堂]H3C东北财经大学WLAN案例 
·[知识课堂]H3C江西无线城市项案例目 


点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息 点击这里给我发消息


开班信息

3月15

H3CNE认证

热报中

4月12

H3C-IMC认证

热报中

3月15

H3CNE认证

热报中

4月19

H3CIE+认证

热报中

4月19

H3C-IMC认证

热报中

3月15

H3CNE培训

热报中

4月06

H3CSE认证

热报中

4月19

H3C无线

热报中

4月06

H3CSE培训

热报中

4月06

H3CIMC培训

热报中

4月06

H3C无线培训

热报中

4月06

H3CEAD培训

热报中

4月19

H3CPME认证

热报中

4月19

H3C安全认证

热报中

4月19

H3CIMC培训

热报中

4月19

H3C无线培训

热报中

4月19

H3CEAD培训

热报中

4月19

H3CPME认证

热报中

4月19

H3C安全认证

热报中

4月19

H3CIMC培训

热报中

4月19

H3C无线培训

热报中

4月19

H3CEAD培训

热报中

4月19

H3CPME认证

热报中

4月19

H3C安全认证

热报中

点击咨询开班情况>>

在线咨询